Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
20x8 LCD
#21
OK. Chef. :-)

10k Poti, hm... malsehen, muss ich übergangsmässig was andres nehmen, hab ja ein Multimeter hier, nachdem ich (und du) jetzt soweit sind, weid ich es mir nicht zerschiessen....

Rückmeldung hoffentlich mit Foto und Fortschritt... vielleicht heut noch :-)

Grüße
#22
Sodele, Statusreport vor dem Bett :-)

Habe alles gelötet, auf Widerstand durchgemessen und Sichtgeprüft.

Rechner an:

Sehe die 1 und 5 Zeile als kompletten schwarzen Balken, sowie die 2 und 6 Zeile als halben Balken (also nur die jeweils 4x4 oberen Pixel eines Characters) auch schwarz.
Habe die Foren durchstöbert, das heisst ja nun nicht mehr als da Strom anliegt und das LCD nicht initialisiert ist. Wobei mich die 2 halben Balkenreihen ein wenig verwundern...

Bios-Einstellungen sind EPP/SPP EPP Mode 1.9. Hätte noch 1.7 zur Auswahl mehr mit EPP gibbet nich. LCDHype gestartet 24x8, Parelleladresse eingestellt, Go gedrückt -> Nichts passiert immernoch 2 ganze, und 2 halbe Balken, Im Script rumgespielt... Immernoch nichts.

Stelle ich mich jetzt zu doof an oder kommt das komplizierte erst noch?

Habe übrigens (achso Vorgeschichte: Die Displays sind Ersatzdisplays für ein TK-Anlagentelefon, eines davon steht hier auf meinem Schreibtisch, das ich wegen der Kontrastspannung und sehr zum Ärgernis meiner Frau auch gleich mal zerlegt hab :-), es wird auch nicht telefoniert, wenn ich löte ;-)) ja, wie gesagt habe übrigens die Kontrastspannungen mal am Telefon abgeommen= Niedrigster Kontrast (nichts zu sehen) 5V Ausgang, höchster Kontrast (auch nichts mehr zu sehen :-) stolze 12,8V.

Ja aber egal, das war ja schon geklärt, aber wieso initialisiert er nicht?
Kann man einfach wenigstens irgendeinen Punkt setzten damit ich sehe das es überhaupt geht?

Und wieso die halben Balken....

Grüße

Fabian
#23
QUOTE
Sehe die 1 und 5 Zeile als kompletten schwarzen Balken, sowie die 2 und 6 Zeile als halben Balken (also nur die jeweils 4x4 oberen Pixel eines Characters) auch schwarz.
Habe die Foren durchstöbert, das heisst ja nun nicht mehr als da Strom anliegt und das LCD nicht initialisiert ist. Wobei mich die 2 halben Balkenreihen ein wenig verwundern...


Das ist vollkommen ok, die erste Hürde ist geschaft. So muss das aussehen. Das das LCD nicht initialisiert kann daran liegen das

(1) du es falsch verlötet hast
(2) du falsch durchgemessen ahst und die pins nicht so stimmen
(3) der treiber nicht mitmacht
(4) das lcd kaput ist

Wobei 4. eher unwahrscheinlich ist smile.gif, prüfe zuerst nochmal die verkabellung nach ob die auch 100% stimmt. immer wieder kommt die klage, es geht nicht, und dann wars die verkabelung. kann das nicht oft genug sagen.

das wiring kuck ich mir morgen nochmal an.
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition
#24
juhu, ne Hürde wars :-)...

1. wird jetzt im ausgergeruhten Zustand nochmal gecheckt
2. ebenfalls
3. wäre ja ein riesen Problem
4. Würde ich auch ausschliessen wollen, da das im Telefon dasselbe gesagt hat und das schon wieder drin ist und geht.

Das mit den Klagen ist wie mit den Suche-Buttons in den Foren.... 99% aller Fragen werden einfach mit ein wenig Suchmühe völlig umsonst.

Grüße
#25
QUOTE
3. wäre ja ein riesen Problem


Nö, ich müsste nurn paar Parameter ändern bzw deine LCD Größe hinzufügen, der Treiber funktioniert ja (also ich ihn zumindest das letzte mal benutzt hab hat er funktioniert rolleyes.gif, lange ists her).

QUOTE
Das mit den Klagen ist wie mit den Suche-Buttons in den Foren.... 99% aller Fragen werden einfach mit ein wenig Suchmühe völlig umsonst.


Nuja suchen ist immer so ne Sache, wenn man nicht auf das richtige Suchwort kommt nützt einem die Suche auch nix. Ich wollte mit meiner Aussage nur bekräftigen das es absolut notwendig ist die Verkabelung erst nochmal genau durchzuschauen.
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition
#26
Hm, also alles nochmals durchgemessen. Habs auch nochmal gelötet, aber leider wird es immer noch nicht initialisiert.

Die Pins stimmen, und die Lötstellen sind auch okay, kein Kabel verwechselt.
Hab auch nochmal das ganze Kabel durchgecheckt. Also Hardware ist m.E. okay

Jetzt bin ich genauso aufgeschmissen wie zuvor..
#27
Update:

So es gibt Neuigkeiten:

Wenn ich den Rechner einschalte, blinken einmal kurz die untersten Pixelreihen der 1 und 5 Zeile auf, wenn sich Netzteil beim ausschalten ebenfalls ausschaltet das ganze nocheinmal.
Ich weiss nicht, ob ich das bisher nur nicht gesehen habe und ob es überhaupt wichtig ist.

Die zweite Sache ist merkwürdiger:
Also Einschalten kurzes aufblinken wie oben beschrieben, dann die beiden Balken. So und nun: kaum ist er dann im Bootvorgang soweit fortgeschritten, dass er die System-Konfiguration anzeigt, also nach dem ersten Bildschirm mit Bios-version, IDE-Erkennung etc. gehen die beiden Balken aus....
Nun ist das Display leer. Spannungen liegen normal an. Egal ob ich mich auf den Kopf stelle oder nicht :-) Das nächste was ich dann wieder sehe ist das kurze obige Aufblinken, wenn der Saft weggeht beim Ausschalten des Rechners.

Es muss auch was mit dem Systemconfiguration-Bildschirm zu tuen haben: wenn ich nämlich ins Bios gehe, bleiben die beiden Balken an....

Rätsel...

Hast du ne Idee?

Bios-Config des LPT: IRQ7/378, EPP/SPP EPP V1.9
Rechner ist ein Pentium mit 233Mhz, Sockel7-Board.
#28
Hm, scheinbar macht er das auch nicht immer, mal bleiben die Balken, mal nicht.... keine Regel erkennbar.
#29
Bin immernoch nicht weiter....

Keiner ne Idee?
#30
war im wochenende smile.gif

ähm das die balken weggehen leigt daran das bestimmt das bios wahllos erstmal irgendwas auf dem lpt schickt und das lcd das als ne initroutine interpretiert.

versuchs mal so. lass das lcd ab, bis windows korrekt hochgefahren ist, mach das lcd dran (balken müssen jetzt da sein) und starte mal lcdhype. die balken müssen jetzt weggehen.

es wäre auch super wenn mal jemand ne bestätigung geben könnte das der treiber überhaupt noch funktioniert. ich decke aber das er korrekt arbeitet, wie gesagt ich habe daran nix gemacht.
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition
#31
Hallo,

hoffe dein WE war erholsam.
Habe schon Stunden zugebracht, mit dem Lcd

Habe deinen Vorschlag befolgt: die Balken bleiben.

Man, it das ein Kampf
#32
hast du noch eines dieser lcds?

wenn ja dann schick mir doch mal eins zu, so kommen wir nicht weiter mit rumrätzeln.
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition
#33
Klar. hab ich. Das würdest du machen? Klasse.

Hier mal Mail-Adresse, dann kannst du mir deine Postadresse zusenden:
mail@fabianwill.de.
#34
naja geht auf jeden fall schneller als hier rumzueiern smile.gif vieleicht is das lcd ja doch was besonderes, hehe
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition
#35
Isses schon da?
#36
jup heute gekommen, am wochenende setz ich mich mal ran.
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition
#37
Super. Schon mal ein dickes Danke.

:-)
#38
Tach auch !

Was musst du für so ein LCD haben ? Würde mich dann beim löten und so weiter beteiligen b.z.w. testen ...

#39
Konnte mich ned einloggen ! Ich weiss ja ned ob Virus zeit u.s.w. hat ! Meiner einer ist im Moment krankgeschrieben und ein 8*24 mit M50530 habs auch !

Falls du die adresse haben willst mail an diver2k@tiscali.de

Gude Nacht nu ...

<b><span style='color:blue'>Diver

<img src='http://www.radio-nachteule.de/extern/livevideo/eule-bannerlive.gif' border='0' alt='user posted image' />

Radio Nachteule - von Nachteulen für Nachteulen

<img src='http://www.danasoft.com/sig/diver.jpg' border='0' alt='user posted image' /></span></b>
#40
weis nicht aber irgendwie passt dein posting nicht smile.gif es geht hier um das 20*8, das 24*8 sollte ohne Probleme mit LCDHype funktionieren, dafür gibt es ja auch einen speziellen Treiber (Samsung 24*8).
Current stable version of LCDHype: 0.7.6
New plugin: Notepad++ Bookmark Manager
New music: Nordwise - Empire transition


Forum Jump:


Users browsing this thread: 1 Guest(s)